summaryrefslogtreecommitdiff
path: root/newlib/libc/sys/configure.in
diff options
context:
space:
mode:
authorPikalaxALT <pikalaxalt@gmail.com>2017-12-15 09:38:53 -0500
committerPikalaxALT <pikalaxalt@gmail.com>2017-12-15 09:39:34 -0500
commitf95a4a932476be2ba99e2fd081e8d2bc6ea12813 (patch)
tree75f67192cb2d7b7b575c94edda318e475239b63c /newlib/libc/sys/configure.in
parentf60aca96985e68c7d8a52eb7bc955fb80e132f73 (diff)
Import newlib and create makefile
Diffstat (limited to 'newlib/libc/sys/configure.in')
-rw-r--r--newlib/libc/sys/configure.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/newlib/libc/sys/configure.in b/newlib/libc/sys/configure.in
new file mode 100644
index 0000000..ea67490
--- /dev/null
+++ b/newlib/libc/sys/configure.in
@@ -0,0 +1,24 @@
+dnl This is the newlib/libc/sys configure.in file.
+dnl Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.5)
+AC_INIT(a29khif)
+
+dnl Can't be done in NEWLIB_CONFIGURE because that confuses automake.
+AC_CONFIG_AUX_DIR(../../..)
+
+NEWLIB_CONFIGURE(../..)
+
+if test -n "${sys_dir}"; then
+ AC_CONFIG_SUBDIRS(${sys_dir})
+fi
+
+CRT0=
+if test -n "${sys_dir}"; then
+ CRT0=crt0.o
+fi
+AC_SUBST(CRT0)
+
+AM_CONDITIONAL(HAVE_SYS_DIR, test x${sys_dir} != x)
+
+AC_OUTPUT(Makefile)