Age | Commit message (Collapse) | Author | |
---|---|---|---|
2018-11-21 | Define first_music_cmd | mid-kid | |
This replaces the uses of $d0 in the audio engine with proper constants. | |||
2018-11-20 | Cosmetic fixes | mid-kid | |
2018-11-18 | Resolve issue #575: Rename text commands | Rangi | |
2018-11-11 | Merge pull request #573 from mid-kid/master | Rangi | |
text_jump → text_far | |||
2018-11-11 | Clarify LEGACY support | mid-kid | |
2018-11-05 | text_jump → text_far | mid-kid | |
The previous name for this was rather misleading. It isn't an actual jump like you'd expect the `jp` instruction to behave as. Instead, it behaves more like a `farcall`. This also makes it consistent with its current command ID name of `TX_FAR`. | |||
2018-10-11 | Stop using __enum__ + 3 | mid-kid | |
Abuse __enumdir__ instead, for better readability. | |||
2018-08-17 | CheckDestinyBond -> CheckFaint | mid-kid | |
Its main function is fainting the opponent and ending the move effect. Updated the comment accordingly. | |||
2018-07-28 | anim_ret_command is an index in a table after all | mid-kid | |
For some reason I thought BattleAnim_Ret was never used, due to how the battle anim loop would be exited early from. It seems I was wrong. Removing commands before anim_ret without it being part of the `enum` seems to break things. | |||
2018-07-18 | Clean up TX_ commands | mid-kid | |
Some of the TX_ commands didn't use the TX_ prefix for their constants, and the label names were inconsistent. I've chosen to adopt the `TextCommand_` prefix as opposed to `Text_`, as it has a clear difference in namespace compared to the possibly-used `Text_` namespace for actual dialogue text. | |||
2018-07-18 | Fix anim_ret_command | mid-kid | |
2018-06-24 | Fix triple newlines left over from removing address comments | Rangi | |
2018-05-05 | fix-various-little-things | mid-kid | |
A compilation of suggestions from the discord that don't deserve separate commits and are not questionable at all™. | |||
2018-04-04 | Rename some battle commands | mid-kid | |
`hittarget` was misleading, as it doesn't actually "hit" the target, it only plays the animation. As such, I've renamed it to `moveanim`. `checkfaint` has nothing to do with checking if the user or target has fainted, instead, it applies wCurDamage onto the target's HP, hitting the substitute if applicable. I've renamed the command to `applydamage` and all of its subfunctions accordingly. | |||
2018-04-04 | Label BattleCommand_BeatUpFailText | mid-kid | |
2018-04-04 | Label bidefailtext | mid-kid | |
This "unknown" battle command is actually used to give the proper fail message to bide. | |||
2018-02-25 | Default macro parameters use recursion; avoids repeating internal structure | Rangi | |
2018-02-25 | * loadmenuheader -> loadmenu (ead103d) | Rangi | |
* objectface -> turnobject (c834bda) | |||
2018-02-03 | map → map_id; map_def → map; map_data → map_attributes | Rangi | |
2018-02-02 | use "x + -1" not "x +- 1" | Rangi | |
(TODO: use "x - 1" once rgbds allows it) | |||
2018-02-02 | spriteface → objectface, consistent with the other script commands | Rangi | |
2018-02-02 | Remove checkmorn/checkday/checknite macros | Rangi | |
2018-02-02 | Script commands don't have underscores | Rangi | |
2018-02-01 | warp_event x, y, map, warp_id | Rangi | |
2018-02-01 | More comments and macros | Rangi | |
2018-01-31 | enum_start like const_def | Rangi | |
2018-01-28 | grep -rl warp_def . | xargs sed -i s/warp_def/warp_event/g | Rangi | |
2018-01-23 | MenuDataHeader → MenuHeader, MenuData2 → MenuData (might complete issue ↵ | Rangi | |
#440) | |||
2018-01-23 | trainers put the class and id first: `trainer YOUNGSTER, JOEY1, ...` | Rangi | |
2018-01-23 | hiddenitem, like itemball and object_event, puts the item first and the ↵ | Rangi | |
event last | |||
2018-01-18 | Better TX_SOUND_* names | Remy Oukaour | |
2018-01-18 | More charmap and home/text.asm documentation for JP chars | Remy Oukaour | |
2018-01-15 | Long lists of db/dw series with struct-defining macros belong in data/ | Remy Oukaour | |
2018-01-13 | Introduce callback, hiddenitem, conditional_event, and cmdqueue macros for ↵ | Remy Oukaour | |
map scripts | |||
2018-01-12 | Use more constants in scripts | Remy Oukaour | |
2018-01-10 | Other files belong in data/battle/ | Remy Oukaour | |
2018-01-01 | Document some more battle animation commands | yenatch | |
2017-12-29 | Fix anim_obj x/y values | yenatch | |
- negative values have no meaning - left in optional tile x/y for backwards compatibility | |||
2017-12-28 | Consistent if/else/endc (matches rept/endr) and DEF (matches BANK/HIGH/LOW) | Remy Oukaour | |
2017-12-28 | Merge branch 'master' of https://github.com/pret/pokecrystal | Remy Oukaour | |
# Conflicts: # macros/scripts/maps.asm | |||
2017-12-28 | endm -> ENDM | xCrystal | |
2017-12-28 | Consistent (x, y) coordinate formatting in map scripts | Remy Oukaour | |
2017-12-28 | Uppercase MACRO and EQU(S) according to the style guide | xCrystal | |
2017-12-27 | Remove redundant data/ filename prefixes | Remy Oukaour | |
2017-12-26 | Use "battle_anims" and "sprite_anims" for clarity, not just "anims" | Remy Oukaour | |
2017-12-26 | Split battle/ into data/ and engine/ components | Remy Oukaour | |
2017-12-26 | Rename: emote_headers, sprite_headers, cry_headers, gfx_headers, tileset_headers | Remy Oukaour | |
2017-12-24 | s/number/scene/, and correct some documentation | Remy Oukaour | |
2017-12-24 | Renaming: (fix #412) | Remy Oukaour | |
- MapTriggers / maptrigger → SceneScripts / scene_script - XYTriggers / xy_trigger → CoordEvents / coord_event - Signposts / signpost → BGEvents / bg_event - PersonEvents / person_event → ObjectEvents / object_event | |||
2017-12-24 | Support old one-argument sound_duty macro, similar to callab/callba legacy ↵ | Remy Oukaour | |
support |