summaryrefslogtreecommitdiff
path: root/newlib/libc/reent/Makefile.am
diff options
context:
space:
mode:
authorPikalaxALT <pikalaxalt@gmail.com>2018-01-03 17:39:24 -0700
committerPikalaxALT <pikalaxalt@gmail.com>2018-01-03 17:39:24 -0700
commita6c1ed4716cf02626ea035beb6dd4a921642ba80 (patch)
treeef582c1b52819e27bdd16097ec03b69799d04ede /newlib/libc/reent/Makefile.am
parentf6c9a624fa8a6878a7fb2b02f55e4990a20feb59 (diff)
Use libc from agbcc instead of standalone newlib\nYou must have AGBCC commit 80d029caec189587f8b9294b6c8a5a489b8f5f88 in order to compile pmd_red.gbalibc
Diffstat (limited to 'newlib/libc/reent/Makefile.am')
-rw-r--r--newlib/libc/reent/Makefile.am55
1 files changed, 0 insertions, 55 deletions
diff --git a/newlib/libc/reent/Makefile.am b/newlib/libc/reent/Makefile.am
deleted file mode 100644
index 20baf3f..0000000
--- a/newlib/libc/reent/Makefile.am
+++ /dev/null
@@ -1,55 +0,0 @@
-## Process this file with automake to generate Makefile.in
-
-AUTOMAKE_OPTIONS = cygnus
-
-INCLUDES = $(NEWLIB_CFLAGS) $(CROSS_CFLAGS) $(TARGET_CFLAGS)
-
-noinst_LIBRARIES = lib.a
-
-lib_a_SOURCES = \
- closer.c \
- reent.c \
- impure.c \
- execr.c \
- fstatr.c \
- linkr.c \
- lseekr.c \
- openr.c \
- readr.c \
- signalr.c \
- sbrkr.c \
- statr.c \
- timer.c \
- writer.c
-
-CHEWOUT_FILES = \
- closer.def \
- reent.def \
- execr.def \
- fstatr.def \
- linkr.def \
- lseekr.def \
- openr.def \
- readr.def \
- signalr.def \
- sbrkr.def \
- statr.def \
- timer.def \
- writer.def
-
-SUFFIXES = .def .h
-
-CHEW = ../../doc/makedoc -f $(srcdir)/../../doc/doc.str
-
-.c.def:
- $(CHEW) < $< > $*.def 2> $*.ref
- touch stmp-def
-
-TARGETDOC = ../tmp.texi
-
-doc: $(CHEWOUT_FILES)
- cat $(srcdir)/reent.tex >> $(TARGETDOC)
-
-impure.o: $(srcdir)/impure.c $(srcdir)/../include/sys/reent.h
-
-CLEANFILES = $(CHEWOUT_FILES) *.ref