summaryrefslogtreecommitdiff
path: root/newlib/libm/Makefile.am
diff options
context:
space:
mode:
authorPikalaxALT <pikalaxalt@gmail.com>2018-01-03 17:39:24 -0700
committerPikalaxALT <pikalaxalt@gmail.com>2018-01-03 17:39:24 -0700
commita6c1ed4716cf02626ea035beb6dd4a921642ba80 (patch)
treeef582c1b52819e27bdd16097ec03b69799d04ede /newlib/libm/Makefile.am
parentf6c9a624fa8a6878a7fb2b02f55e4990a20feb59 (diff)
Use libc from agbcc instead of standalone newlib\nYou must have AGBCC commit 80d029caec189587f8b9294b6c8a5a489b8f5f88 in order to compile pmd_red.gbalibc
Diffstat (limited to 'newlib/libm/Makefile.am')
-rw-r--r--newlib/libm/Makefile.am52
1 files changed, 0 insertions, 52 deletions
diff --git a/newlib/libm/Makefile.am b/newlib/libm/Makefile.am
deleted file mode 100644
index b481b88..0000000
--- a/newlib/libm/Makefile.am
+++ /dev/null
@@ -1,52 +0,0 @@
-## Process this file with automake to generate Makefile.in
-
-AUTOMAKE_OPTIONS = cygnus
-
-if NEWLIB_HW_FP
-SUBDIRS = mathfp common
-SUBLIBS = mathfp/lib.a common/lib.a
-else
-SUBDIRS = math common
-SUBLIBS = math/lib.a common/lib.a
-endif
-
-noinst_LIBRARIES = libm.a
-
-libm.a: $(SUBLIBS)
- rm -f $@
- rm -rf tmp
- mkdir tmp
- cd tmp; \
- for i in $(SUBLIBS); do \
- $(AR) x ../$$i; \
- done; \
- $(AR) $(AR_FLAGS) ../$@ *.o
- $(RANLIB) $@
- rm -rf tmp
-
-$(SUBLIBS): all-recursive
-
-info_TEXINFOS = libm.texinfo
-
-libm.info: targetdep.tex math/stmp-def
-
-stmp-targetdep: force
- rm -f tmp.texi
- targetdoc=`pwd`/tmp.texi; \
- for d in $(SUBDIRS); do \
- (cd $$d && $(MAKE) doc) || exit 1; \
- done
- $(SHELL) $(newlib_basedir)/../move-if-change tmp.texi targetdep.tex
- touch $@
-
-targetdep.tex: stmp-targetdep ; @true
-
-math/stmp-def: stmp-targetdep ; @true
-
-.PHONY: force
-force:
-
-CLEANFILES = tmp.texi targetdep.tex stmp-targetdep
-
-ACLOCAL_AMFLAGS = -I ..
-CONFIG_STATUS_DEPENDENCIES = $(newlib_basedir)/configure.host