summaryrefslogtreecommitdiff
path: root/engine/menus
AgeCommit message (Collapse)Author
2022-04-16Additional vc_asserts (#906)HEADmastervulcandth
2022-03-12Allow alternate labels for patch namesRangi
2022-03-12Build the Virtual Console patch with `make crystal11_vc` (#882)vulcandth
Fixes #813
2021-11-23Use ~X instead of $ff ^ XRangi
2021-05-30Move the dbbw, dbww, and dbwww macros to legacyRangi
2021-04-19Use rgbds 0.5.0Rangi
2020-12-23Rename some labelsRangi
- Remove "Buffer" suffix from some byte and word quantities - Change "Ptr" to "Pointer" Fixes #789
2020-11-17Correct some filename commentsRangi
2020-11-09Replace $0 with 0 for "ld l, a / ld h, 0" idiomRangi
2020-11-03Identify more uses of wBuffer1-6Rangi
2020-11-01Identify some more labels, and make some more consistentRangi
2020-10-30Identify wSpriteAnimDict key constantsRangi
2020-10-28Identify more WRAM labels, and start a <X>_DummyFunction label conventionRangi
2020-10-28Replace many '; unused' with '; unreferenced'Rangi
2020-10-27Identify remaining Mystery Gift labels and constantsRangi
Source: https://projectpokemon.org/home/forums/topic/43930-mystery-gift-reverse-engineering-of-ir-protocol/
2020-10-26Comment, remove, or revise many unreferenced labelsRangi
2020-10-06Identify some unnamed labelsRangi
2020-10-04Identify more unnamed labelsRangi
2020-10-04Identify some more unnamed labelsRangi
2020-08-27Fix some constants surrounding sprite animationsmid-kid
Also commented the use of the field surrounding the struct initialization functions. SPRITEANIMSTRUCT_0C -> SPRITEANIMSTRUCT_VAR1 SPRITEANIMSTRUCT_0D -> SPRITEANIMSTRUCT_VAR2 SPRITEANIMSTRUCT_0E -> SPRITEANIMSTRUCT_VAR3 SPRITEANIMSTRUCT_0F -> SPRITEANIMSTRUCT_VAR4 BATTLEANIMSTRUCT_01 -> BATTLEANIMSTRUCT_OAMFLAGS BATTLEANIMSTRUCT_ANON_JT_INDEX -> BATTLEANIMSTRUCT_JUMPTABLE_INDEX BATTLEANIMSTRUCT_0F -> BATTLEANIMSTRUCT_VAR1 BATTLEANIMSTRUCT_10 -> BATTLEANIMSTRUCT_VAR2
2020-08-27Document splash screen animationmid-kid
2020-08-18Add wTitleScreenSelectedOption constantsmid-kid
2020-08-05Document wTitleScreenSelectedOption variablemid-kid
2020-08-03Minor title screen fixesmid-kid
2020-08-03Identify constant in NamingScreen_IsTargetBoxRangi
2020-07-13Disassemble the final English debug ROMRangi
2020-07-01Identify more labels, and use the jumptable macro when possibleRangi
2020-06-21Comment more ROM labels as unreferencedRangi
(Some unreferenced labels are above code which is still used via fallthrough!)
2020-06-21Replace "Unreferenced" labels with "; unreferenced" commentsRangi
2020-06-21Remove some more raw addressesRangi
2020-06-18Harmonize engine/menus with pokegoldRangi
2020-06-17Harmonize engine/{movie, pokemon} with pokegold (renames GetSRAMBank to ↵Rangi
OpenSRAM) To do: engine/{menus, overworld}
2020-06-16Harmonize some more symbols with pokegoldRangi
2020-06-15Identify wObjectPrioritiesRangi
2020-06-13Label some mobile addresses, and revise some commentsRangi
2020-05-29Rename ScrollingMenu_UpdateDisplay.string_2485f (#726)Lhivorde
2020-05-25Some uses of SCREEN_WIDTH and SCREEN_HEIGHTRangi
2020-05-17Miscellaneous cleanup noted in #709Rangi
2020-05-16Format all CopyTilemapAtOnce variations the same wayRangi
2020-04-17More miscellaneous fixes (see #709)Rangi
2020-04-04`dsprite y, ypx, x, xpx, off, attr` -> `dbsprite x, y, xpx, ypx, off, attr`Rangi
2020-04-04Miscellaneous fixes:Rangi
- `hSecondsBackup` -> `hUnusedBackup` - `ld bc, hBGMapAddress + 1` -> `bccoord -1, -2, 0` - Identify some `.asm_XXX` labels
2020-03-21rgbds supports 'X - 1' instead of 'X + -1'Rangi
2020-03-01Change how some PNG graphics are formattedRangi
2020-02-28Identify remaining gfx/unknown filesRangi
2020-02-23Replace some "idiotic", "wtf", "stupid interns" comments with more common ↵Rangi
"useless", "pointless", "could have done X instead"
2020-02-21RTC -> UpdateTimeAndPalsmid-kid
Rename clear misnomer. Most of the related functions in that file aren't really aptly named but I don't know good names right now.
2020-02-16PanicResetClock -> ClearClockmid-kid
Funky name that only exists based on what it's used for, not so much what it is.
2020-02-13Standardize on lowercase Tilemap and Attrmapmid-kid
We used to have a mixture of TileMap and and Tilemap, as well as the similar AttrMap. Standardize on one.
2020-02-13InitSpriteAnimStruct <-> _InitSpriteAnimStructmid-kid
These were the wrong way around, as the function in home should not be prefixed