summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBryan Bishop <kanzure@gmail.com>2013-08-03 16:10:52 -0500
committerBryan Bishop <kanzure@gmail.com>2013-08-03 16:10:52 -0500
commit28490230cf68f8045fc63a8c7d3de19c7c1d3bcd (patch)
treec4d1a3acbc7d34b77a890f8e19a8d7253917be8c /setup.py
parenta14c36eadb75ea3d6fbc4cb3f382d7c9785d9fe9 (diff)
make a basic python module
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py44
1 files changed, 44 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..c5f45bb
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,44 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+
+import os
+import sys
+
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+# for uploading to pypi
+if sys.argv[-1] == 'publish':
+ os.system('python setup.py sdist upload')
+ sys.exit()
+
+# There's some intersection with requirements.txt but pypi can't handle git
+# dependencies.
+requires = [
+ "mock",
+]
+
+setup(
+ name="pokemontools",
+ version="1.0",
+ description="Tools for compiling and disassembling Pokémon Red and Pokémon Crystal.",
+ long_description=open("README.md", "r").read(),
+ license="BSD",
+ author="Bryan Bishop",
+ author_email="kanzure@gmail.com",
+ url="https://github.com/kanzure/pokemon-reverse-engineering-tools",
+ packages=["pokemontools"],
+ package_dir={"pokemontools": "pokemontools"},
+ include_package_data=True,
+ install_requires=requires,
+ platforms="any",
+ classifiers=[
+ "License :: OSI Approved :: BSD License",
+ "Operating System :: OS Independent",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2.7",
+ ]
+)