Age | Commit message (Collapse) | Author |
|
|
|
|
|
* Update sign to bg_event #289
* Rename warp to warp_event
* Replace object to object_event
* Move warp macro parameter from warp x, y, id, map to warp_event x, y, map, id
|
|
- FOR loops
- {interpolation}
- REDEF EQUS
- \# for all macro args
|
|
(#318)
|
|
|
|
|
|
|
|
|
|
Instead of building a semicolon-separated "array" of warp_to coordinates in _WARP_TO_BUFFER, just declare a new EQUS for each one: _WARP_TO_NUM_1, _WARP_TO_NUM_2, etc. Then have def_warps_to output and PURGE each one of them.
|
|
|
|
|
|
|
|
|
|
'dbmapcoord' has X, Y order like other coordinate-related data macros
|
|
|
|
|
|
|
|
|
|
implementations
|
|
|
|
|
|
Fixes #260
|
|
MACRO/ENDM, etc)
|
|
|
|
by rgbds 0.4.0)
|
|
While doing so I replaced the StopAllMusic macro with a SFX_STOP_ALL_MUSIC constant and applied it throughout the code.
|